What do I need to run Periscope on my device?

Last Updated: May 08, 2017 04:44PM PDT

To use Periscope, you need an Apple device running iOS 8.1 or greater or an Android device running 4.4 (aka Kit Kat) or higher. Your Android device will need both front and back cameras in order to be compatible.

Some devices cannot support the required OS due to hardware limitations. If your device isn't supported, you can always watch broadcasts on the web.
5721fee031da38acbccc5386ae0a12bc@periscopeapp.desk-mail.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete